Interview Questions for AIX


INTERVIEW QUESTIONS AND ANSWERS FOR AIX


1.How do I know if my volume group is normal, big, or scalable?
Run the lsvg command on the volume group and look at the value for MAX PVs. The value is 32 for normal, 128 for big and 1,024 for scalable volume group.

2.How do I create a volume group?
Use the following command, where s partition_size sets the number of megabytes (MB) in each physical partition where the partition_size is expressed in units of MB from one through 1,024. (It’s one through 131,072 for AIX 5.3.)
mkvg -y name_of_volume_group -s partition_size list_of_hard_disks
The partition_size variable must be equal to a power of two (for example: one, two, four or eight). The default value for standard and big volume groups is the lowest value to remain within the limitation of 1,016 physical partitions per physical volume. The default value for scalable volume groups is the lowest value to accommodate 2,040 physical partitions per physical volume.

3.How can I change the characteristics of a volume group?
You use the chvg command to change the characteristics of a volume group.

4.How do I create a logical volume?
#mklv -y name_of_logical_volume name_of_volume_group number_of_partition

5.How do I increase the size of a logical volume?
To increase the size of the logical volume represented by the lv05 directory by three logical partitions, for example, type extendlv lv05 3.

6.How do I display all logical volumes that are part of a volume group (e,g, rootvg)?
You can display all logical volumes that are part of rootvg by typing the following command: #lsvg -l rootvg/

7.How do I list information about  logical volumes?
command to display information about the logical volume #lv1: lslv lv1.
8.How can I clone the rootvg?
You can run the alt_disk_copy command to copy the current rootvg to an alternate disk. The following example shows how to clone the rootvg to hdisk1: alt_disk_copy -d hdisk1.]

9.How do I replace a disk?
#extendvg VolumeGroupName hdisk_new
#migratepv hdisk_bad hdisk_new
#reducevg -d VolumeGroupName hdisk_bad

10.How do I mirror a logical volume? 

#mklvcopy LogicalVolumeName Numberofcopies

#syncvg VolumeGroupName


11.How can I display or set values for network parameters?
The no command sets or displays current or next boot values for network tuning parameters

12.How do I get the IP address of my machine?
Type one of the following: ifconfig -a or host Fully_Qualified_Host_Name. For example, host cyclop.austin.ibm.com.

13.How do I identify the network interfaces on my server?
Either of the following two commands will display the network interfaces: lsdev -Cc if or ifconfig -a. To get information about one specific network interface, for eaxample tr0, run the command ifconfig tr0.

14.How do I activate a network interface?
To activate the network interface tr0, run the command ifconfig tr0 up.

15.How do I display routing table, interface and protocol information?
To display routing table information for an Internet interface, type netstat -r -f inet. To display interface information for an Internet interface, type netstat -i -f inet. To display statistics for each protocol, type netstat -s -f inet.

16.How will you create a file if a disk is given to you?
#mkvg –y datavg –s 128 hdisk1 (pv name)
#mklv -y datalv –t jfs2 datavg 1
#crfs –v jfs2 –d datalv –g datavg –a size=10M –m /fs1

17.Difference between JFS & JFS2?
JFS:
JFS is normal filesystem. We cannot create large files in JFS.
Files can be access dynamically.
Max file system size=1TB
Max file size=64GB
Inode size=128b
JFS2:-
Can create a large size filesystems.
Files can be access accordingly as required. (not randomly or sequentially)
Max files system size=4PB
Max file size=4PB
Inode size=512

18.How will you find the inode number?
# ls –li
# istat /etc/passwd

19.How will you find LTG size?
#lsvg vgname
#lquerypv –M hdiskname

20.How will you change LTG size?
#rmdev -l hdiskx
#chdev -l hdiskx -a max_transfer=0*80000
#mkdev -l hdiskx

21.How will you find whether a quorum is up or not?
# lsvg vg name

22.How to copy a LV from one VG to another?
# cplv -v <new vg name> <sourcelvname>

23.Mirroring concept?

Check disk size belong to vg , take two same size disk to mirror

# bootinfo –s hdisk2

#lsvg –p rootvg

Add one more disk of same size of already have disk having rootvg.
# extendvg rootvg hdisk2
# lsvg –p rootvg
Now mirror vg with background sync LV. It sync LVs in background with new LVs
# mirrorvg –s rootvg
Create a boot image
# bosboot –ad /dev/hdisk2
#bosboot –ad /dev/hdisk1
Add a blv
record of newly added disk, first check and then add.
# bootlist –m normal -o

#bootlist –m normal hdisk2 hdisk1

24.How will you unmirror a VG if a PV gets failed?

First check the blv record using,

# bootlist –m normal –o

Remove the old blv record, using

# chpv –c hdisk2
# bootlist –m normal hdisk1
# bootlist –m normal hdisk2
Now unmirrorvg
# unmirrorvg rootvg hdisk2
# reducevg rootvg hdisk2
#lsvg –p rootvg
# lspv
# bootlist –m normal –o


25.How will you change a PP size?
PP size can be changed using a T-factor. If not then add a partitions in VG by adding one disk.
# chvg –t3 rootvg

 26.T – Factor?
T – factor means that it will change the pp size to increase the efficiency of vg
#chvg –t16 datavg
Cal-if suppose that datavg pp size is 1016 we can take t factor is 16 then it comes to 2048 and pv contains in vg is 2.

27. What is the default PP Size in AIX?
64 MB

28.How will you rename a VG?
Unmount all filesystems in VG.
# umount /test (mount point name)
#varyoffvg datavg
#exportvg datavg0
Importvg with new name
# importvg –y newvg hdisk4

29.What is major number?
A major number refers to a type of device. A device number is a major number, and a minor number specifies a particular device of that type or sometimes the operation mode of that device type.

30.What will you do if a disk gets failed?
diag command

31. How to enable & disable quorum?
#chvg –vy pv_name
#chvg –vn pv_name
#chvg –Qn vgname
#chvg –Qs vgname

32.What are the types of error?

1.H/W error

2. S/W error

3. Operator error

4. Unknown error.


33.What are the error levels severity?

1. permanent

2. Temporary

3. Informational
4. Unknown.


34.What is the command to see the error log?

# errpt –a

# errpt –d H [H/W]

# errpt –d S [S/W]


35.What is the command to clear the errorlog?
# errclear

36.What is the command to increase the size of error log when it is full?
#usr/lib/errdemon –s ____ [ size ]

37.What is the command to start , stop, restart and list a demon?
# startsrc –g [ Demon name ]
# stopsrc [Demon name ]
# refrest [Demon name ]
# lssrc –al

38.When does error demon start in boot process?
rc.boot phase 3

39.Which file that error daemon stay?
/usr/lib/errdemon

40.Two states of device availability and explain them?
Available state and defined state. When device is in defined state it means it cannot use. Not in ready state. Run cfgmgr try to make available known in the system that device. Available state means that device is ready to use
# lsdev –Cc disk
It displays which disks are available

41.How will you check whether a device is installed or not?
# lsdev –Cc disk

42.How to change a 64 bit kernel to 32 bit kernel?

1. Modify the /usr/lib/boot/unix directory and the /unix directory to be   a symbolic link to the binary for the desired kernel.

2. Run the bosboot command to write a new system boot image.

3. Reboot the system.

The path name of the 64-bit kernel is /usr/lib/boot/unix_64, and the

path name of the multiprocessor versions of the 32-bit kernel is

/usr/lib/boot/unix_mp.

# ln -sf /usr/lib/boot/unix_mp /unix
# ln -sf /usr/lib/boot/unix_mp /usr/lib/boot/unix
# lslv -m hd5
# bosboot -ad /dev/ipldevice
# shutdown -Fr
# bootinfo -K (should now be 32)


43.How to change a 32 bit kernel to 64 bit kernel?
To truly change the kernel to 64-bit from 32-bit, the system must be at the AIX® 5.1 or AIX 5.2levels.
# bootinfo –y
It shows a kernel is either 32-bit or 64-bit.
To truly change the kernel to 64-bit from 32-bit, the system must be at the AIX® 5.1 or AIX 5.2levels.
# bootinfo –y
It shows a kernel is either 32-bit or 64-bit.
To change to a 64-bit kernel, enter the following commands:
# ln -sf /usr/lib/boot/unix_64 /unix
# ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix
# lslv -m hd5
# bosboot -ad /dev/ipldevice
# shutdown -Fr

44. How many VGs can be created in a LVM?
255 lv and any no. of vg can create.

45.Types of VG & explain about them?
Normal vg -32 pv, 256 lv
# mkvg –y normvg –s 128 hdisk4
Big vg :- 128pv,512lv
# mkvg -B –y bigvg –s 128 hdisk9
Scalable vg: -1024pv, 4096 lv
# mkvg –S –y scalvg –s  512 hdisk1

46. How to convert a normal VG to big & scalable VG and also Big to Scalable VG?
#chvg –B vgname      /big vg
# chvg –S/-G vgname  /scale vg

47.What is VGDA, VGSA?
VGDA: Volume Group Descriptor Area. It contains the information about volume group to which the physical volume belongs to. It also contains the information about physical partitions, logical partitions and logical volumes.
VGSA: Volume Group Status Area it contains the information about physical partition from all physical volumes of the same volume group. It contains the status of VG

48.Default dump device?
hd6

49.Default secondary dump device?
/dev/sysdumpdevnull

50.How find a system dump?
#sysdumpdev -L

51.Where the file does the paging space stay?
/etc/swapspaces

52.How will check whether a fix is installed or not?
# instfix –ik  ptfname

53.What are the two states of installation?
Applied and commit state
In applied state if want to do any changes on installed software then we can do
But in commit the changes are not allowed to do. Once did installation.
A committed fileset update cannot be rejected.
Output from the installp -s command, which is used to get a list of applied software fileset     updates and updates that are available to be either committed or rejected.

54.How will you reject a committed fileset?
# installp –r –g fileset name

55.How will you check whether service pack is installed or not?
# oslevel –s
56.What is the latest OS level?
#oslevel -rq

57.How will you check whether software is installed or not?
# lslpp -L |grep -i   (software_name)

58.How do you find history of a file set?
  #lslpp –h

59.How to remove a failed package installation?
#installp -C

60.How do remove the entries of the device in the odm?
#rmdev -dl


61.What are the types of ODM Database ?

Pre-defined database PdDv, PdAt

Customised database CuDv, CuAt


62.ODM Commands.
odmcreate: To customize Odm
To remove ODM: odmdrop
odmdelete: To remove object from ODM
To see info in ODM  odmget
To change the fields in object class  odmchange
To add object to ODM  odmadd

63. Types of Installation?
New and complete overwrite
Migration
Preservation

64.Where does log files resides?
AIX logs messages as specified in /etc/syslog.conf file.

65.How to unlock user account?
chuser –a account=true username

66. How to lock a user’s account?
#chuser account_lock=true username

67.How do u take backup of file systems?
#mksysb –ie  /dev/rmt0

68.How will u restore a file from already take backup using backup?
#restore -xvqf /dev/rmt0

69.How will u append a file to a previous archive take by Tar?
#tar -rvf /dev/rmt0

70.What command to take backup other vg’s?
# savevg –if /dev/rmt0 /vgname

71.What command to restore backup of non – rootvg?
# restvg  –x –d –f /dev/rmt0
  1. Anonymous

    February 19, 2014 at 11:31 am

    thanks musab for the interview questions

  2. Musabuddin Syed

    February 20, 2014 at 7:16 am

    Welcome dear,It's my pleasure,
    can I know ur name as well.
    Thanks

  3. Sairam P

    June 1, 2014 at 3:52 pm

    "Musab bhai" feeling good to see your blog..
    and found good aix questions on your blog, which at least it reminds me something of AIX part.
    Good Going Bro!
    Cheers 🙂

  4. Musabuddin Syed

    June 2, 2014 at 5:44 am

    Hey Sai!.
    Thank you so much mate for wishes and kind words.

  5. Adnan Chaudhry

    March 5, 2016 at 7:13 pm

    Hello Sir,

    I just found this, I wanted thank you for all the hard work and you put into doing all this. This is very helpful, inshAllah this will all help me in finding a position. Thank you again!

  6. Musabuddin Syed

    March 7, 2016 at 3:09 am

    Thanks Adnan,
    its always a pleasure to help.
    i'm happy you found it useful

    All the best

  7. Amritbir Singh

    August 22, 2016 at 1:17 pm

    Musab Bhai, Keep up the good work. You rock……. Amrit

Comments are closed.